Tip #001 - Cockpit Saitek (yoke+pedals)

Tutte le discussioni sull' hardware dedicato a Flight Simulator & Co.

Moderatori: ardix, renato

Rispondi
Avatar utente
GianP
Sviluppatore VVT
Messaggi: 483
Iscritto il: lunedì 16 giugno 2008, 8:58
Località: Varese - Italy
Contatta:

Tip #001 - Cockpit Saitek (yoke+pedals)

Messaggio da GianP » giovedì 4 febbraio 2010, 15:44

Cominciamo dalla configurazione: W7Ult. - FS9.1 - drivers Saitek dai CD "nelle scatole" (quindi non cercati in rete). Il tutto US/English.
Quanto di seguito potrebbe quindi non applicarsi ad altre configurazioni, ..... ma vale la pena controllare/provare, anche in FSX, se esiste una corrispondenza da qualche parte.
Come sempre, prima di procedere, salvare una copia della FS9.cfg!!!

Il retroscena:
Negli ultimi giorni stavo provando le nuove aviosuperfici (FS9) con il C150L di Guidée François-Denis (fravin) e Franckart Yves (Frank00), a mio giudizio un "farfallotto free" veramente eccezionale.
Riscontravo pero' notevoli difficolta' nel raggiungere la velocita' di rotazione entro le piste piu' corte, Castellamonte e Moncrivello (ed anche sull'asfalto della "mia" Calcinate).
Pensavo: Vabbe' che i 100 cavalli dell'aereo sono pochi e stanchi, pero' su queste piste sicuramente opera qualche "150". E siccome il modello di volo, per quanto permette FS9, e' "super" ....... c'e' qualcosa che non va!

E' finita che, indagando all'interno del file "Previous flight.FLT" (che viene salvato ad ogni uscita da FS9) ho rilevato che i freni, destro e sinistro, erano sempre, almeno, a circa 11%. E non c'era modo di scendere a zero, anche tenendo i miei "zamponi" ben lontano dalla pedaliera o effettuando calibrazioni a ripetizione.

Sono cosi' arrivato a modificare, a mano, la "solita" FS9.cfg secondo quanto riportato qui sotto.
I parametri originali, come impostati dal "trio" menzionato nella configurazione iniziale, sono quelli nel commento, a destra dopo il ";".

Codice: Seleziona tutto

[JOYSTICK_MAIN {61F62990-D49D-11DE-8001-444553540000}]
 // Saitek Proflight Rudder pedals 
AXIS_EVENT_00=AXIS_LEFT_BRAKE_SET
AXIS_SCALE_00=-128			; Fixed - def was -64
AXIS_NULL_00=01				; Fixed - def was 36
AXIS_EVENT_01=AXIS_RIGHT_BRAKE_SET
AXIS_SCALE_01=-128			; Same
AXIS_NULL_01=01				; Same
AXIS_EVENT_05=AXIS_RUDDER_SET
AXIS_SCALE_05=127			; Fixed - def was 64
AXIS_NULL_05=36
Il vostro GUID, nel titolo della sezione della FS9.cfg, dovrebbe essere differente (dipende dal nome utente windows) e la seconda riga e' un mio commento aggiunto.
Con l'impostazione qui sopra i freni restano, al minimo, allo 0.08% e la frenata non inizia anche solo tenendo i piedi sulla pedaliera (cosa che succede con AXIS_NULL_nn=00)


Poi, visto che le cose si erano risolte per il meglio e pur non riscontrando problemi in "area cloche", ho notato gli stessi valori per il Yoke, ed ho provato a modificarli allo stesso modo (senza il "meno" necessario per i freni).
Ebbene, la cloche e' diventata molto-molto piu' dolce, precisa e progressiva nelle manovre.

Codice: Seleziona tutto

[JOYSTICK_MAIN {29858E10-D4F8-11DE-8001-444553540000}]
 // Saitek Proflight Yoke System
AXIS_EVENT_00=AXIS_AILERONS_SET
AXIS_SCALE_00=127			; Smooth! - def was 64
AXIS_NULL_00=36
AXIS_EVENT_01=AXIS_ELEVATOR_SET
AXIS_SCALE_01=127			; Smooth! - def was 64
AXIS_NULL_01=36
AXIS_EVENT_02=AXIS_THROTTLE_SET
AXIS_SCALE_02=127
AXIS_NULL_02=1
............
...........
(continua)
That's all folks.
GianP
  • GianP
_______________________
http://gianp.altervista.org
_______________________

Avatar utente
ruggy71
Sviluppatore VVT
Messaggi: 636
Iscritto il: lunedì 12 marzo 2007, 12:13

Re: Tip #001 - Cockpit Saitek (yoke+pedals)

Messaggio da ruggy71 » giovedì 4 febbraio 2010, 15:46

approfitto della tua esperienza per chiederti una cosa...
La mia pedaliera, configurata correttamente (almeno credevo), si comporta in questa maniera :

- freni off
- atterraggio
- frenata prima di girare sulla taxiway....
- rilasciando i pedali, rimangono attivi i freni

Questo su FSX....e' capitato anche a te ?

Avatar utente
GianP
Sviluppatore VVT
Messaggi: 483
Iscritto il: lunedì 16 giugno 2008, 8:58
Località: Varese - Italy
Contatta:

Re: Tip #001 - Cockpit Saitek (yoke+pedals)

Messaggio da GianP » giovedì 4 febbraio 2010, 15:54

No, mai rilevato nulla di simile (W7-FS9.1)
Se FSX ha la FSX.cfg, verifica bene il parametro AXIS_NULL.
Dai miei esperimenti non comanda solo la zona degli assi in cui i comandi sono "morti" ma ha anche strani effetti secondari.

Ciao, GP
  • GianP
_______________________
http://gianp.altervista.org
_______________________

Rispondi